Comment calculer une durée entre deux dates dans Excel

///Comment calculer une durée entre deux dates dans Excel

Visualisez le tutoriel :

ou suivez les indications ci-dessous :

Pour calculer, dans Excel, une durée entre 2 dates (ex : âge ou ancienneté, etc…), il faut entrer les 2 dates dans 2 cellules différentes  puis faire la différence entre elles.

Nous allons ici calculer la durée entre le 05/09/1950 (Cellule B3) et le 28/05/2013 (Cellule C3).

Entrer la formule en D3 =+C3-B3

Durée jours entre 2 dates2

 

Le résultat s’affiche alors sous forme de date, il faut donc redéfinir le format de la cellule en Nombre :

format-nombre

Le résultat s’affiche alors en nombre de jours (ici 22 911 jours entre nos deux dates).

Pour que cette durée s’affiche en nombre d’années, il suffit de diviser ce chiffre par 365,25 jours (qui correspond au nombre moyen de jours par an). On obtient alors le nombre d’années qui sépare les deux dates :

duree anneesduree annees2

 

 > > > > >   Besoin d’aide ? Contactez Sitadi pour établir un devis.  < < < < < 

Cet article vous a aidé ? Rendez-vous sur la page Facebook et cliquez J’aime ! 
2018-05-07T16:35:12+00:00By |Excel, Formules|16 Comments

16 Comments

  1. mohande 21/09/2014 at 14 h 43 min

    =DATEDIF(A1;A2;”Y”)&SI(DATEDIF(A1;A2;”Y”)>1;” ans, “;” an, “)&DATEDIF(A1;A2;”YM”) &” mois et “&DATEDIF(A1;A2;”MD”)&SI(DATEDIF(A1;A2;”MD”)>1;” jours”;” jour”)

  2. Ida BONNIN 21/09/2014 at 21 h 47 min

    Merci Mohande pour cette formule qui fonctionne parfaitement.

  3. Axelle A. 30/04/2015 at 15 h 29 min

    Bonjour, ça tombe bien, je cherchais ça aussi, donc merci à tous les intervenants.

    Juste “petit truc”, la longue formule de Mohande, hélas, ne fontionnait pas à cause des » « que j’ai remplacé par des ” ” mais ensuite j’ai des erreurs et Excel ne dit jamais comment réparer ça. Tant pis, j’ai quand même la formule. Merci bien.

  4. ravenet shirley 21/06/2015 at 16 h 26 min

    bonjour

    je suis confrontée à un autre problème car sur un tableau dans le lequel je contrôle les délais de traitement de mes collaborateurs, j’ai une colonne avec date arrivée et une autre date de transmission qui n’est pas toujours renseignée donc j’aimerai pouvoir calculer si cellule vide alors date arrivée moins date d’aujourd’hui?
    pouvez vous m’aider

  5. sitadi 21/06/2015 at 19 h 36 min

    Bonjour,
    dans votre cas, il faut ajouter une formule si. Cette formule dirait : si la cellule qui contient la date de transmission est vide, alors “date d’arrivée” – “aujourd’hui”, sinon “date d’arrivée” – “date de transmission”.
    Supposons que votre date d’arrivée est en cellule A1 et votre date de transmission en cellule A2, la formule serait la suivante : =SI(B1=””;A1-AUJOURDHUI();A1-B1).
    Est-ce que cela fonctionne pour vous ?
    Tenez moi au courant 🙂

    * les guillemets dans la formule s’affichent mal, il s’agit en fait simplement de mettre deux guillemets à suivre (sans espace entre les deux) pour indiquer qu’il n’y a rien.

  6. Laurent 15/07/2015 at 11 h 14 min

    J’aurais aimé connaître la formule permettant de diviser une durée en jours au format semaine si la durée est égale à 7, en jour si elle ne dépasse pas 7 et en semaine et jour si elle dépasse 7. Merci par avance.

  7. sitadi 16/07/2015 at 21 h 17 min

    Bonsoir,
    J’utiliserais la solution suivante : imaginons votre durée en cellule A1, votre formule pourrait être : =SI(A1=7;"1 semaine";SI(A1=1;A1&" jour";SI(A1<7;A1&" jours";ARRONDI.INF(+A1/7;0)&" semaine(s)"&" et "&A1-(ARRONDI.INF(+A1/7;0))*7&" jour(s)")))

  8. Gérard Cavelot 01/04/2016 at 2 h 11 min

    Pour Sitadi : Le procédé marche très bien et la précision me suffit, mais je fait un travail d’historien et la formule ne marche que pour les dates dépassant 1900, sinon ça indique “VALEUR”.
    Il se trouve que je bosse sur le haut moyen âge !
    J’ai trouvé une combine, je fait naître et mourir mes personnages avec 1000 ans de plus, exemple : untel est né en 945, j’inscris 1945. Ca marche, mais c’est curieux qu’on ne puisse pas aller au delà de 1900 ?
    Merci d’avance pour éclairer ma lanterne.

  9. sitadi 04/04/2016 at 18 h 21 min

    En effet, Excel ne reconnait pas les dates antérieures au 01/01/1900. Votre combine est la meilleure solution.

  10. CAUSSADE 26/05/2016 at 9 h 56 min

    Je cherche à calculer l’ancienneté d’un salarié de sa date d’embauche à aujourd’hui mais la formule avec le DATEDIF proposé par Mohande ne fonctionne pas sur mon mac 🙁

    Qui peut m’aider, merci 🙂

  11. sitadi 26/05/2016 at 18 h 59 min

    Vous pouvez m’envoyer votre fichier à cette adresse mail : contact@sitadi.fr, j’y regarderai si vous le souhaitez.

  12. Irene 16/02/2017 at 17 h 31 min

    Bonjour
    J’ai essayé la formule mais le résultat affiche #NOMBRE!
    J’ai essayé avec le format de cellule : Nombre sans décimal, cela ne fonctionne toujours pas

    Pouvez-vous m’aider SVP

    Merci

    Bet

  13. sitadi 16/02/2017 at 18 h 36 min

    Bonjour, vous avez dû faire une erreur dans la formule, envoyez moi votre fichier si vous voulez que j’y jette un oeil 😉 à l’adresse mail ci-arès : contact@sitadi.fr.

  14. Irene 16/02/2017 at 19 h 00 min

    Bonjour

    merci de votre aide

    Comment convertir les années en jours ou en mois selon votre technique dans le tuto

    Merci

  15. sitadi 14/03/2017 at 22 h 17 min

    Pour convertir les années en jour, il faut multiplier les années par 365.25, et pour les convertir en mois, les multiplier par 12

  16. fatma 04/01/2018 at 22 h 35 min

    Je cherche aussi à calculer l’ancienneté d’un salarié de sa date d’embauche à aujourd’hui mais la formule avec le DATEDIF proposé ne fonctionne pas
    Pouvez-vous m’aider SVP
    Merci

Leave A Comment

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.